SCSS error causing build problems - solved

I’m having build problems on my latest Course in a Box repo, apparently caused by an SCSS error, which is bewildering because I haven’t edited any of the css files and I have working repos using identical files! Github gives me this error message:

Your site is having problems building: Your SCSS file css/p2pustrap-custom.scss has an error on line 6: File to import not found or unreadable: vendor/rfs. Load paths: _sass /hoosegow/.bundle/ruby/2.7.0/gems/jekyll-theme-primer-0.5.4/_sass /hoosegow/.bundle/ruby/2.7.0/gems/jekyll-theme-primer-0.5.4/_sass /hoosegow/.bundle/ruby/2.7.0/gems/jekyll-theme-primer-0.5.4/_sass

The ‘line 6’ referred to above contains the following:
@import "bootstrap/scss/bootstrap";

Can anyone help? Thanks in advance, Lucy

I’ve fixed this build error by replacing vendor in my .gitignore file with vendor/bundle, as suggested here I’ll reply again if this has unintended consequences!

1 Like

Hi @LucyTallents,

That error is weird indeed. The missing file is part of the bootstrap code and lives here and it looks like the build process doesn’t look for it in the right place.

I don’t understand how the adding vendor/bundle solved the issue, but glad it’s gone, maybe it was something temporary with GitHub pages!

1 Like